double buffer patch of pxafb for linux-2.6.26

The latest Angstrom development environment gives me a nice linux 2.6.26 kernel but there is a drawback. The frame buffer driver degrades a bit. Overlay function and higher color depth support is gone.

The source code of frame buffer driver in 2.6.23 version can not be compiled against 2.6.26 environment.

Based on the same strategy as 2.6.23 version, I wrote a small patch to handle double buffering and pan function for 2.6.26 version. Following is the patch file which is working fine for me.

o pxafb_doublebuffer.patch.bz2

The touchscreen driver is not working satisfactorily. Once I manage to make it work, I'll upload a pactch on this blog.

posted by 安藤恐竜 at 09:41 | Comment(5) | TrackBack(0) | 日記




・マイブログの【設定】 > 【広告設定】 より、「60日間更新が無い場合」 の 「広告を表示しない」にチェックを入れて保存する。